Support for dashcam is unreachable, Cam looses it's config

Trying to open a case and get support for my 6 months old dash cam that keeps loosing it’s configuration. When I hit submit I get a message: “Requested Parameters do not meet encryption requirements”.
There is no phone number or email address to contact support either. Did you guys had to make it this difficult to get support?

1 Like

Are you trying to reach support on the community, or on their website? And have you tried using a different computer, or maybe your phone?

Hi!

Firstly, sorry that you’re experiencing this problem.

Unsure why you’re receiving this error - but i’ve taken the liberty of sharing this post with our Support team. I have your email address, so they’ll follow up on this question. :handshake:

So, I don’t have a support request. But when I try to log into the main Aukey site (not the community site) I have the same issues as OP. So it seems like there is a problem with the main site login, and it is probably impacting the support logins as well. Just some extra information to pass onto your support team.

@TaborTech,
I tried my other laptop & that one failed too. Then I tried to use two different other browsers (Chrome and Explorer). The problem is YOU (your Support Website) not me. As you see other people are reporting the same problem.
Thanks
GadgetMan

@Dane_Aukey,
Thank you for taking the liberty and reporting it to support. As you see in my response to @TahaEng, other people are complaining too and it is not only me. Obviously you have some configuration problem with your website. I still have not recieved any response from support nor I know any other means to contact support. Please escalate this issue, as I am without Dash cam for 5 days now.
Thanks & Regards

You’re welcome. Again, sorry for the delay in someone getting back to you.

I’ve escalated the issue and been told someone will contact you ASAP.

Thanks for your patience. :pray:

Just so you know, I do not work for aukey. I was just trying to help you out. I’m glad that the issue has been raised to their team. Hopefully it will start working soon.

@TaborTech,
Hi TaborTech. Sorry, I thought you are the moderator from Aukey and trying to blame me or my computer. But you helped me to get the attention of Aukey, though no one has contacted e yet for three day now. Thanks again

  • Gadgetman

I am having the exact same situation. My aukey dashcam is not holding its settings, I’ve tried to contact aukey via the website and get nowhere either.failed submission

Thanks for informing us of this issue. Our CS specialist @Kelly_AUKEY will reach you to help out.

Buongiorno a tutti. Ho provato in tutte le maniere ad accedere alla sezione per la dash cam, ho chiesto come fare al supporto AUKEY, continuano a dirmi che le vendono su AMAZON !!! Questo lo so !!! Il problema è che sul sito AUKEY ,non esiste più il link che ti porta alla sezione delle dash cam, come se AUKEY avesse deciso di non produrle più e di non dare più nemmeno il supporto. Sono mesi che va avanti questa storia…probabilmente devono vendere quelle che ha in magazzino AMAZON e poi liberi tutti. Io volevo acquistarne 3…ma dovrò comprare di altre marche se non mi dicono come fare per tornare a visualizzare la sezione dedicata alla dash cam del sito AUKEY…di AMAZON non mi interessa…voglio sapere perchè non si riesce più ad accedere alla dfash cam sul sito AUKEY. Se hanno deciso di non produrle più che lo dicessero…e non continuare a dare risposte evasive senza senso…parlando di AMAZON…DOVE SI VEDONO LE DASH CAM SUL SITO AUKEY !!!

Hi @FABIO

I’m afraid i’ll have to share this with our customer service team to handle - sorry to hear you’re having issues with the dashcam.

@Kelly_AUKEY