PA-B4 Charger May Have "Fried" My HP Laptops USB-C Ports?

Hi, sorry for the double post, but when I posted this in Wall Chargers forum, I noticed there hadn’t been a post there for almost a month so I didn’t want this to go unseen. My issue:

I have an HP Elitebook x360 830 G6 laptop. Last night the battery ran down and without thinking/checking compatibility, I plugged into the 65w charge port on the Aukey.

When I tried to use the USB-C port for docking, etc. in the morning, the port was dead. So was its “sister” port right next to it on the side panel. (Note, USB devices worked fine when plugged into the HP’s older-type USB port.)

The HP’s normal AC 65-watt charger is rated for 19.5v@3.3 amps. I see that the Aukey PA-B4 is rated at up to 20v@3.2 amps.

I do not see the HP Elitebook listed in any Aukey product descriptions or Amazon product information as HP Elitebook compatible.

My company’s tech support department believes that I “fried” my USB-C Ports by using this charger. Do you think they may be right? Thanks.

Resolution: Ports were not “fried” but could only be recovered by a full BIOS install.

Lesson learned: Do not use a non-HP charging accessory on Elitebook x360 laptops.