Earbuds EP-T10 not connecting nor pairing

I have bought Aukey EP-T10 in October 2019.
They have worked only once and since then they have never paired anymore.
I’ve sent mails to Amazon (December 2019) and also to support@aukey.com (January 2020) but have never received any help or answer.
Could you please tell me what to do to make it work or propose a replacement of the product? I really think the earbuds are dysfunctionning and that the multi-function touch button from the right earbud is corrupted with maybe a contact failure.
When I bring the two earbuds out from the powerbox, they do not connect with each other nor do they go into “pairing mode”. I also tap twice on the right earbud as suggested in the user manual but nothing comes out of this.
The same goes if I try to only use the right earbud from the powerbox.

Hope you’ll have an idea to make it work.
Best regards,
FBM

Hi FBM,

I am really sorry to hear about the malfunctioning of our earbuds. Please contact our CS specialist @Kelly_AUKEY for technical support or a replacement.

Best regards,
Simon

3 Likes

Many thanks @Simon_AUKEY : how can I contact @Kelly_AUKEY?

Best regards,
Fabrice

1 Like

@FBM Welcome to Aukey Community :pray:

Aukey Support Personnel @Kelly_AUKEY is already on this communication, you can reach Kelly via Private Message, please drop a note with all the details,

hope this helps!

2 Likes

I just need to get used to the platform (in short: find how to PM) but your message is clearly very helpful.

if you just click the name it will give you the message option

2 Likes

I’ve already done this, but I can’t find any “message options” when I open @Kelly_AUKEY 's profile.
I also tried to message from my AUKEY-inbox and it’s the same: does not work. Maybe I need to wait a bit before those options get activated.

Sorry, I don’t know why you don’t see the message option.
I’m fairly sure Dane already copied Kelly in on the issue anyway so you should be ok

You might be right, she might be cc-ed and informed of my problem.
Here is what I see while clicking on her name:

@FBM follow the steps with the red highlight

1 Like

Nice share for this. Thanks @CK-Techie

@FBM As they’ve mentioned, you have indeed been added to the queue for our CS team to reach out. Please bare with us - we’re aware and are dealing with it :slight_smile:

1 Like

Thx for helping!
Eager to have your pieces of advice :slight_smile:

Hi,
I have the same issue. has this been solved?

Hi I recommend that you message us via the support email - support@aukey.com - as this will be best for these kinds of technical questions. :pray:

In the mean time, do check the forum for any possible troubleshooting methods for the T10’s. :slight_smile:

I’m on my second pair of aukey t10s after the last one had problems and now when I take the buds out of the case they will say “disconnected, pairing, disconnected” and not connect and I can’t seem to fix this

Hi @Lamppost

As I just mentioned in the other post, please check the forum carefully and try all possible troubleshooting methods. If nothing works, please let our support team know - support@aukey.com