DR02 dashcam issues

Hi everyone,
I’m experiencing issues with my DR02 dashcam. My setup is as follows:

  • Front cam
  • Rear cam
  • GPS antenna
  • Aukey hardwire kit

It used to work great but recently I noticed purple artifacts on the rear camera’s recordings that renders the image unusable.
It also sometimes just hangs, sometimes when I get back to my car I notice the image on the display has frozen. I’ve also experienced this while driving. The only way to get the camera to respond again is disconnecting it from the OBD port for about 10 seconds or so.

I’ve also had it start up and greet me with the welcoming screen like it came new out of the box, the date and time were reset to factory default. I closed the menu and it did start recording. Later that day the date and time were correct again, so some weird things going on there.

The setup seems more stable with the rear camera disconnected so that might be the culprit but I’m not sure yet.
I’ve also reformatted the SD card which did not make a difference. I’ve yet to try a different card altogether.

Is there some additional troubleshooting that can be done of perhaps a firmware update?

Maybe there were too many words in my initial post. Let’s try the shorter version:
Rear cam causes issues, what now?

Hi,

I have the same issue with mine since a few weeks now. Tried all solutions stated in this post, it sometimes works again, but for a short period of time.

Also tried with two differrents SD card, from 2 differents manufacturers, formated with Windows and formated with the dashcam. Also did multiple factory reset on the dashcam.

No permanent solution found for now.