CB-C71 Firmware update for MacBook Pro 16

I just realized that my hub is charging at 60W. While scouring the Internet, I found out that the CB-C71 received a firmware update to allow for 100W passthrough charging. Where can I find this firmware? I looked in the Manuals and Firmware section, but couldn’t find any files for this product.

Any help is greatly appreciated.

1 Like

Hi @tekashi69

Thanks for leaving us your question. I’ve tagged our prod dev team into this @Simon_AUKEY and he’ll find out about this.


I’m PM’ing you an update to the firmware, as I cannot send files here. We’ll be adding it to our website for future reference, but it’s the quickest way for you to get it :slight_smile:


I’m looking for this firmware update as well.

@Dane_AUKEY I also just bought one of these off Amazon. I have no idea if it has the latest firmware or not. Can I so get that link just in case I need to update it? Thanks.

Hi guys, ill check if its been added to the main website if not ill share it directly here with a drive file.


Hi there, I’m also interested in a firmware update to best use my CB-C71 hub with my MacBook Pro 16". Thanks

Please get it here.


Thank you Simon.

Can it be done on a Mac? The instructions seem to be Windows related…and my only Windows laptop doesn’t have a usb-c port…

Sorry, so far the firmware upgrade can only be done on a Win PC. If there’s a Mac version coming out, I’ll let you know asap.

Would this be possible on a Windows PC via a USB-C to USB-A adapter? I think I may have one laying around at the office (once I’m finally able to get back in there).

It is quite likely you can do it on a mac via a virtual machine running vmware workstation. You would just need to be sure to assign the full hub to the VM.

Alternatively, setup bootcamp on your mac and dual boot to windows. Always convenient to have options.

1 Like

I’ve attempted to upgrade the firmware using a Windows VM. I made sure to pass the full hub to Windows (disconnecting everything from the hub to make things simpler), but it gives an error message as shown below:

Do you get that error as soon as you connect it, or while trying to upgrade the firmware?

As soon as connecting.

That happens with certain USB devices - sometimes even on my windows 10 base machine. It knows the device is there, knows what type it is and just won’t recognize it.

Often disconnecting and reconnecting will help, sometimes rebooting the system will help. Some devices just don’t to work at all. I would have it all hooked up and connected to the running VM, and then reboot the OS inside the VM (that should leave the device connected) and see if it recognizes the device on restart.

My inclination if that doesn’t work would be to find a friend or coworker that is on windows and see if they could update it for you.

I am always very cautious with firmware updates, even if everything appears to be working perfectly. So I don’t know if this is a good option or not - but the last option is to try running the firmware update software even with Windows reporting the device as unrecognized. That communication is at a different level than OS support for all the components. So if you run updater, and it detects the hub is there and can communicate to it, it may be able to update even without the OS fully recognizing it. If it can’t recognize the hub and communicate to it, it shouldn’t do anything at all. But I can’t guarantee anything down that path.

I’ve now tried setting up a Boot Camp partition and installed Windows 10. While it doesn’t give the error message above any further, it still does not recognize the hub inside of the firmware update software. There is no possible way to run the update, since the device is never recognized on the system. I’m thinking I’m left with returning the device and trying on a new one…

I have tried running Windows 10 Pro in a VM, as a BootCamp installed OS, and also tried using Crossover, but none of them detect the hub. Any further guidance on how to update the firmware from a MacBook Pro?

Same for me too. I also tried my Lenovo Yoga 900’s USB-C port as well. I get a grey box like srthimsen does in the image above. I tried contacting support and they just are not very helpful. I noticed that some people have different placement of the USB ports, so perhaps there is different hardware versions out there. I have the newer model with the SD card slot in between two USB ports. I may have to return this unless Aukey helps soon. Very disappointing as I had been a good customer of Aukey until my last purchase, where now I have two defective products.

Hi Simon, thanks for the firmware, was able to load it and good charging on the MacBook Pro 16. However it seems not able to fully load all 3 USB ports. It works fine with 2 USB ports plugged in, but whenever a 3rd device is plugged in, it’ll disable the entire hub.

Any idea if this can be fixed? Not sure if anyone else is encountering this problem.